After upgrading to Yosemite, my browser based WebCam won’t work. What can I do?

Mac users who require Java and who have installed OS X Yosemite may have discovered that a prior version of Java is no longer functioning under OS X 10.10, and that older installers don’t work to install Java in Yosemite.

Additionally, a fresh install of Yosemite does not include Java at all.

If your Mac running OS X Yosemite (OS 10.10) you will need Java for application compatibility with the Kaltura screen capture tool. You can manually install an older version of Java that is compatible with OS X 10.10 directly from Apple.

A legacy Java-compatible version is available from Apple.